Our card transactions will be temporarily offline to update a configuration change. Will notify once service is resumed shortly.
Incident Report for Solid Status
Resolved
This incident has been resolved.
Posted Dec 15, 2023 - 15:17 PST
Update
The issue has been resolved.
Posted Dec 15, 2023 - 15:15 PST
Investigating
We are currently investigating this issue.
Posted Dec 15, 2023 - 14:42 PST